Annulé

update [url removed, login to view] to run with matplotlib 1.1.1

I want the open source project [url removed, login to view] to be updated to work with the current version (1.1.1) of Matplotlib ( [url removed, login to view] ).

The last version of faces (0.11.7) is based on Matplotlib 0.8.5, and a there is a git branch which supports 0.9.1. Since then, significant changes have been made , especially the refactoring of transforms (see [url removed, login to view] ). Therefore, a refactoring of faces charting feature is needed. Apparently the most critical module is [url removed, login to view] ([url removed, login to view];a=blob;f=faces/charting/[url removed, login to view];h=6a0a3fa78681f2da466529ca9afdd1722a3e16cb;hb=68a8b4621b9a18b2c42c717a58704c6a26f98331 ) but others have to be updated also.

Please apply only if you have a good knowledge of matplotlib.

The project will be considered finished when example "[url removed, login to view]" runs and produces the same results charts as in [url removed, login to view] . Code will be published in a branch of [url removed, login to view]

Compétences : Python

Voir plus : code refactoring, net api, hb, git, matplotlib python, python matplotlib, net based code, scm open source, html transforms, transforms, python api, code net open source, changes net, update source, module project based net, branch module, good knowledge net, python open source project, open python project net, https http, http https, net project notes, module net, blob, API python

Concernant l'employeur :
( 1 commentaire ) Crissier, Switzerland

N° du projet : #2387135

2 freelance ont fait une offre moyenne de 250 $ pour ce travail

mseroney88

I'm very Good at Python programming with an experience of more than ten years. I'm sure you'll be amazed at what I can do for you.

250 $ USD en 10 jours
(0 Commentaires)
0.0
ngirard

Python is my language of choice since 2003, and I'm familiar with matplotlib.

250 $ USD en 10 jours
(0 Commentaires)
0.0